lkml.org 
[lkml]   [2009]   [Sep]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] x86: apic: convert BUG() to BUG_ON()
On Sat, 12 Sep 2009, Daniel Walker wrote:

> For one it condenses duplicate code (i.e. the if()). If the BUG_ON()
> macro gets updated with something new, all the users get the updates
> automatically. The other thing is your re-using potentially more
> advanced code that's inside the macro. In this case it's fairly trivial,
>
> #define BUG_ON(condition) do { if (unlikely(condition)) BUG(); } while(0)
>
> So we're getting the benefit on the new "unlikely" in the apic code.
> unlikely/likely calls will usually allow the compiler to create smaller,
> and or, more optimized code.

For non-x86 platforms the use of the BUG_ON() macro may result in more
efficient code GCC may not be able to optimise to with if (...) BUG();.
For example the macro may expand to inline assembly with a conditional
trap instruction GCC would not emit for an if () clause. While GCC does
have a __builtin_trap() intrinsic that could be optimised if alone in a
conditional block, such usage may not be frequent enough for a dedicated
optimisation to be provided and build-time efficiency of the compiler does
matter too, so such an optimisation might be of too questionable a value
to incur an additional performance hit for the compiler.

Just a general note on patches of this kind, or to put it short, yes I
agree it's a good idea.

Maciej


\
 
 \ /
  Last update: 2009-09-13 00:55    [W:0.045 / U:0.460 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site