[lkml]   [2009]   [Aug]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: memleaks, acpi + ext4 + tty
    On Mon, Aug 31, 2009 at 12:43 PM, Luis R. Rodriguez<> wrote:
    > On Mon, Aug 31, 2009 at 12:33 PM, John W.
    > Linville<> wrote:
    >> On Mon, Aug 31, 2009 at 12:30:15PM -0700, Luis R. Rodriguez wrote:
    >>> On Mon, Aug 31, 2009 at 11:37 AM, Luis R. Rodriguez<> wrote:
    >>> > OK I tried this, I even 'rm -rf * ; git checkout -f' and ..
    >>> > merge-2009-08-28 tag yields the same issues, long lag upon bootup with
    >>> > some kmemleaks I cannot even get to check. So somehow something is
    >>> > different between merge-2009-08-28 and Linus' rc8. This is just
    >>> > bizarre so to be even safer I'm just going to do a fresh git clone on
    >>> > wireless-testing.
    >>> Hey John so I tested wireless-testing on the merge-2009-08-28 tag on a
    >>> fresh git pull and verified this is indeed busted for me. Although I
    >>> had tried hpa's linux-2.6-allstable on HEAD just to be sure I am now
    >>> building Linus' tree from a fresh git clone on the v2.6.31-rc8 tag
    >>> just to be double check this was indeed not a 2.6.31-rc8 issue but
    >>> instead *something* on wireless-testing. What that something is is
    >>> unclear to me still, I guess after all these tests I'll run a manual
    >>> diff as git doesn't seem to be picking anything up.
    >> As you determined, there is no difference between merge-2009-08-28
    >> and v2.6.31-rc8.  If one works and the other doesn't, then the main
    >> thing not working will be git...
    > Hm that would suck big time. At any rate, even if it was git
    > wireless-testing seems to have an issue right now. I'll confirm
    > shortly with Linus' own tree.
    >> What is linux-2.6-allstable?
    > hpa's collection of 2.6 stable kernels, including extraversion stuff.
    >> My guess is that the culprit is between
    >> v2.6.31-rc8 and whatever is at the head of linux-2.6-allstable.
    > But the issue is *not* in linux-2.6-allstable, it is only present on
    > wireless-testing, and I went as far back as merge-2009-08-28. I was
    > using whatever tag was available prior to you moving to rc8, and that
    > worked.

    Good news is Linus' rc8 tag *has the same issue* so the reason why
    wireless-testing has it is rc8 *does indeed have it*.

    So Peter, if there is something extra or missing from
    linux-2.6-allstable head it certainly fixed my issues, will have to
    try a new respin of it to ensure it wasn't a fluke. Odd thing too
    though is even my distribution kernel (karmic rc8 generic) works fine.

    At least now I can safely bisect between rc7 and rc8, or pull the
    kmemleaks branch and see if that fixed.

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2009-08-31 22:01    [W:0.065 / U:23.124 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site