lkml.org 
[lkml]   [2009]   [Aug]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] x86: fix build with older binutils and consolidate linker script
>>> "H. Peter Anvin" <hpa@zytor.com> 24.08.09 09:13 >>>
>On 08/23/2009 11:55 PM, Jan Beulich wrote:
>>>>> "H. Peter Anvin" <hpa@zytor.com> 21.08.09 22:23 >>>
>>> On 08/18/2009 08:51 AM, Jan Beulich wrote:
>>>>
>>>> #define VSYSCALL_ADDR (-10*1024*1024)
>>>> -#define VSYSCALL_PHYS_ADDR ((LOADADDR(.data.read_mostly) + \
>>>> - SIZEOF(.data.read_mostly) + 4095) & ~(4095))
>>>> -#define VSYSCALL_VIRT_ADDR ((ADDR(.data.read_mostly) + \
>>>> - SIZEOF(.data.read_mostly) + 4095) & ~(4095))
>>>> +#define VSYSCALL_PHYS_ADDR ((LOADADDR(.data) + SIZEOF(.data) + \
>>>> + PAGE_SIZE - 1) & ~(PAGE_SIZE - 1))
>>>> +#define VSYSCALL_VIRT_ADDR ((ADDR(.data) + SIZEOF(.data) + \
>>>> + PAGE_SIZE - 1) & ~(PAGE_SIZE - 1))
>>>>
>>> I'm missing something with this chunk... could you please explain?
>>
>> There are two changes here: One is the adjustment to properly use the
>> new preceding section's name, and the other is to replace the hard coded
>> 4095 by PAGE_SIZE-1.
>>
>
>Hm. I'm wondering if an actual (NOLOAD)/@nobits section wouldn't be
>better...

For what? The immediately preceding section?

In any case, it would seem that this would be an independent patch on top
of mine...

Jan



\
 
 \ /
  Last update: 2009-08-24 09:23    [from the cache]
©2003-2011 Jasper Spaans