lkml.org 
[lkml]   [2009]   [Aug]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 06/17] vfs: Rename generic_file_aio_write_nolock
On Fri, Aug 21, 2009 at 07:56:17PM +0200, Jan Kara wrote:
> On Fri 21-08-09 19:30:34, Christoph Hellwig wrote:
> > On Fri, Aug 21, 2009 at 07:23:56PM +0200, Jan Kara wrote:
> > > generic_file_aio_write_nolock() is now used only by block devices and raw
> > > character device. Filesystems should use __generic_file_aio_write() in case
> > > generic_file_aio_write() doesn't suit them. So rename the function to
> > > device_aio_write().
> >
> > This might turn into nitpicking, but it's really only useful for
> > writing to block devices. Raw isn't a real character interface but
> > basically a convuled way to open a block device using O_DIRECT.
> >
> > So I would recommend to renamed it to blkdev_aio_write, move it to
> > fs/block_dev.c and stop exporting it.
> But what should 'raw' use then? It can be compiled as a module so it
> needs to call something that's exported.

Oh, ouch - I didn't think that we would allow it to be modular. We need
to keep exporting it then. Hopefully the name change keeps people from
using it in filesystems.



\
 
 \ /
  Last update: 2009-08-21 20:11    [W:0.036 / U:3.740 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site