lkml.org 
[lkml]   [2009]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] Help Resource Counters Scale better (v4.1)
* KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com> [2009-08-13 01:28:57]:

> Balbir Singh wrote:
> > Hi, Andrew,
> >
> > Does this look better, could you please replace the older patch with
> > this one.
> >
> > 1. I did a quick compile test
> > 2. Ran scripts/checkpatch.pl
> >
>
> In general, seems reasonable to me as quick hack for root cgroup.
> thank you.
>
> Reviewed-by: KAMEAZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
>

Thanks, yes, we still need to do the percpu counter work, but this
will give us breathing space to do it correctly and define strict and
non-strict accounting.

> Finally, we'll have to do some rework for light-weight res_counter.
> But yes, it will take some amount of time.
> My only concern is account leak, but, if some leak, it's current code's
> bug, not this patch.
>

Yeah.. we'll need to check for that.

> And..hmm...I like following style other than open-coded.
> ==
> int mem_coutner_charge(struct mem_cgroup *mem)
> {
> if (mem_cgroup_is_root(mem))
> return 0; // always success
> return res_counter_charge(....)
> }
> ==
> But maybe nitpick.
>

Yes, we can refactor for simplication, but we'll need some exceptions.
I'll do that as an add-on patch.



--
Balbir


\
 
 \ /
  Last update: 2009-08-12 19:23    [W:0.417 / U:0.072 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site