lkml.org 
[lkml]   [2009]   [Jul]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [patch -mm v2] mm: introduce oom_adj_child
On Thu, 30 Jul 2009, KAMEZAWA Hiroyuki wrote:

> 1. IIUC, the name is strange.
>
> At job scheduler, which does this.
>
> if (vfork() == 0) {
> /* do some job */
> execve(.....)
> }
>
> Then, when oom_adj_child can be effective is after execve().
> IIUC, the _child_ means a process created by vfork().
>

It's certainly a difficult thing to name and I don't claim that "child" is
completely accurate since, as you said, vfork'd tasks are also children
of the parent yet they share the same oom_adj value since it's an
attribute of the shared mm.

If you have suggestions for a better name, I'd happily ack it.

> 2. More simple plan is like this, IIUC.
>
> fix oom-killer's select_bad_process() not to be in deadlock.
>

Alternate ideas?

> rather than this new stupid interface.
>

Well, thank you. Regardless of whether you think it's stupid or not, it
doesn't allow you to livelock the kernel in a very trivial way when the
oom killer gets invoked prior to execve() and the parent is OOM_DISABLE.


\
 
 \ /
  Last update: 2009-07-30 11:33    [W:0.079 / U:0.796 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site