lkml.org 
[lkml]   [2009]   [Jul]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: [PATCH] Staging: hv: Transform PDEVICE_OBJECT and DEVICE_OBJECT typedefs into their corresponding structs
    Date
    On Tuesday 28 July 2009 16:41:23 Greg KH wrote:
    > On Tue, Jul 28, 2009 at 10:30:44AM +0200, Nicolas Palix wrote:
    > >
    > > Remove typedef DEVICE_OBJECT and use a struct with the same name
    > > instead. The new struct name uses lower case (struct device_object).
    >
    > This should be called "struct hv_device" instead, care to respin the
    > patch like that to keep us from having to change it again? :)
    >
    > thanks,
    >
    > greg k-h
    >
    Ok. So, I guess the pattern for the other typedef is to strip the _OBJECT
    suffix when present, and always add the prefix hv_, right ?

    --
    Nicolas Palix


    \
     
     \ /
      Last update: 2009-07-28 17:05    [W:0.019 / U:30.500 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site