lkml.org 
[lkml]   [2009]   [Jul]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: next: sfi build fails when !CONFIG_ACPI
On Thu, 23 Jul 2009 16:43:30 +0800
Alexander Beregalov <a.beregalov@gmail.com> wrote:

> 2009/7/17 Alexander Beregalov <a.beregalov@gmail.com>:
> > 2009/7/17 Len Brown <lenb@kernel.org>:
> >>> drivers/sfi/sfi_core.c: In function 'sfi_init':
> >>> drivers/sfi/sfi_core.c:346: error: 'acpi_disabled' undeclared
> >>> (first use in this function)
> >>> drivers/sfi/sfi_core.c:346: error: (Each undeclared identifier is
> >>> reported only once
> >>> drivers/sfi/sfi_core.c:346: error: for each function it appears
> >>> in.)
> >>>
> >>>
> >>> $ grep ACPI .config
> >>> # Power management and ACPI options
> >>
> >> It builds for me.
> >> Please send me the complete failing .config
> >
> > Attached (x86_64)
>
> Still fails for me in the same way,
> X86_64
> next-20090723

sorry for the late response, please try the following patch:

diff --git a/drivers/sfi/sfi_core.c b/drivers/sfi/sfi_core.c
index 62e2f98..fa66824 100644
--- a/drivers/sfi/sfi_core.c
+++ b/drivers/sfi/sfi_core.c
@@ -361,9 +361,6 @@ static __init int sfi_find_syst(void)

void __init sfi_init(void)
{
- if (!acpi_disabled)
- disable_sfi();
-
if (sfi_disabled)
return;

Thanks,
Feng

\
 
 \ /
  Last update: 2009-07-23 12:19    [W:0.055 / U:1.508 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site