lkml.org 
[lkml]   [2009]   [Jul]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 2.6.30.2: does not boot
> > I am seeing a similar problem (no hang but an immediate reboot) on the
> > same distro. I tried to bisect but got no good kernel in the end.

> > To clarify things I recompiled again 2.6.30.1 with the orginial .config
> > and it also failed to boot (I was happy to have renamed it so the
> > working kernel was still available). I suspected a recent gcc 4.3
> > upgrade so downgraded gcc, but no luck, still getting the same problem.
> > So for now I am quite stuck, but there is clearly a bad problem
> > somewhere...

* Linus Torvalds <torvalds@linux-foundation.org> [2009-07-20 11:16]:
> Hmm. So you _had_ a working self-compiled 2.6.30 kernel at some point?

Yes, my case is very similar to the one described by Kiko Piris, and
I also think this is getting off topic.

> One thing to look out for is that a compiler upgrade/downgrade will be
> invisible to the kernel build system, so if you downgrade the compiler
> and recompile, you may not actually recompile things at all.

I tried the bisect with the same compiler and then for other tests
I recompiled from scratch each time on a tmpfs to make sure I was not
messing things up. On this machine, ccache is not used.

So I am suspecting a recent glibc or binutils upgrade (gcc downgrade did
not solve the problem) and even if some people noticed problems with
2.6.30.2, my issue seems different and only distro-related.

--
Damien Wyart


\
 
 \ /
  Last update: 2009-07-20 22:33    [W:0.093 / U:4.616 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site