[lkml]   [2009]   [Jul]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] tracing/filters: Improve subsystem filter
>>> bool dry_run sounds perhaps more intuitive for what is happening there.
>> I guess you "try_run". ;)
>>> Because "apply" is surprising in a "add_thing" function, it's like
>>> a field to confirm that we know what what we are doing :)
>>> (May be I start to become a PITA with my naming worries, especially
>>> since I'm usually not good at it in my patches :)
>> I'll take "try_run". Naming is often hard for me.
> No I really meant "dry run"
> "Try run" is already a function that would implicitly fit into
> every function :)
> Ie, dry run means:
> "Behave as if you were truly doing it, just to see if it works.
> But don't really do it"

Got it. Thanks. :)

 \ /
  Last update: 2009-07-20 03:35    [W:0.033 / U:2.852 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site