lkml.org 
[lkml]   [2009]   [Jul]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [rfc -tip] lib,rb-tree - introduce rb_for_each helper
On Sun, Jul 12, 2009 at 02:00:09AM +0400, Cyrill Gorcunov wrote:
> perftools already use a number of opencoded
> for() iterators over rbtree. The patch introduce
> rb_for_each helper for this purpose.
>
> Signed-off-by: Cyrill Gorcunov <gorcunov@openvz.org>
> ---
>
> The real conversion for this macro usage should be
> done later.
>
> Also I think having rb_for_each_entry for being used
> with container_of inbetween could be convinient as
> well.
>
> Anyway if we don't need such a helper -- just drop
> the patch.
>
> include/linux/rbtree.h | 3 +++
> 1 file changed, 3 insertions(+)
>
> Index: linux-2.6.git/include/linux/rbtree.h
> =====================================================================
> --- linux-2.6.git.orig/include/linux/rbtree.h
> +++ linux-2.6.git/include/linux/rbtree.h
> @@ -145,6 +145,9 @@ extern struct rb_node *rb_prev(const str
> extern struct rb_node *rb_first(const struct rb_root *);
> extern struct rb_node *rb_last(const struct rb_root *);
>
> +#define rb_for_each(nd, root) \
> + for (nd = rb_first((root)); nd; nd = rb_next(nd))
> +
> /* Fast replacement of a single node without remove/rebalance/add/rebalance */
> extern void rb_replace_node(struct rb_node *victim, struct rb_node *new,
> struct rb_root *root);


Nice idea!
This pattern is often taken in perfcounter tools.
Also to complete this pattern, an abstract container retrieval
would be also useful as an iterator:

#define rb_for_each_entry(tpos, pos, root, memb) \
for (pos = rb_first(root); pos && tpos = rb_entry(pos, typeof(*tpos), memb); \
pos = rb_next(pos->memb, typeof(*pos), memb))

Or something like that...




\
 
 \ /
  Last update: 2009-07-12 00:31    [W:0.048 / U:0.684 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site