[lkml]   [2009]   [Jun]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/6] cpumask: introduce zalloc_cpumask_var
Andrew Morton wrote:
> On Sat, 06 Jun 2009 14:50:36 -0700 Yinghai Lu <> wrote:
>> bool alloc_cpumask_var_node(cpumask_var_t *mask, gfp_t flags, int node);
>> bool alloc_cpumask_var(cpumask_var_t *mask, gfp_t flags);
>> +bool zalloc_cpumask_var_node(cpumask_var_t *mask, gfp_t flags, int node);
>> +bool zalloc_cpumask_var(cpumask_var_t *mask, gfp_t flags);
>> void alloc_bootmem_cpumask_var(cpumask_var_t *mask);
> ick. cpumask_var_node_zalloc() would be better.
> Yes, the other functions were incorrectly named, but that's no reason
> to incorrectly name these also.

problem is that we would using alloc_cpumask_var and zalloc_cpumask in different case.

so we may need to change these name at the same time. otherwise will cause confusing. No?


 \ /
  Last update: 2009-06-07 00:11    [W:0.144 / U:1.864 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site