lkml.org 
[lkml]   [2009]   [Jun]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Problems with snd-hda-intel on hp 6930p (2.6.30)
At Tue, 30 Jun 2009 16:15:37 +0200,
Rafael J. Wysocki wrote:
>
> On Tuesday 30 June 2009, Rafael J. Wysocki wrote:
> > On Tuesday 30 June 2009, Takashi Iwai wrote:
> > > At Mon, 29 Jun 2009 20:37:09 +0200,
> > > Rafael J. Wysocki wrote:
> > > >
> > > > Hi Takashi,
> > > >
> > > > I have a problem with snd-hda-intel from 2.6.30 on an hp EliteBook 6930p, which
> > > > is that the sound is not audible, although everything appears to work just
> > > > fine. Except maybe that when the box is rebooted and KDE (3.5) is started,
> > > > the master control is "muted" and the led indicator next to the keyboard shows
> > > > "no sound". Then, changing the "muted" status of the master control doesn't
> > > > change the state of the led indicator and vice versa (the two things appear to
> > > > be totally independent of each other).
> > > >
> > > > Can you please tell me what I can do to debug this issue?
> > >
> > > Could you run alsa-info.sh with --no-upload option on both "muted"
> > > and "not muted" states, and attach the generated files?
> >
> > Sure. In the meantime it turned out that after a power off and cold boot the
> > status of the master control is 'on', but the led indicator shows 'no sound', so
> > there are 5 outputs:
> > * alsa-info-postboot.txt - after power off and cold boot
> > * alsa-info-led.txt - led indicator switched to 'on' when it was in the
> > alsa-info-postboot.txt state
> > Now I switched to AC power and rebooted the box without powering off:
> > * alsa-info-muted.txt - initial state with the 'muted' master control
> > * alsa-info-on.txt - master control switched to 'on' when it was in the
> > alsa-info-muted.txt state
> > * alsa-info.txt - led indicator switched to 'on' when it was in the
> > alsa-info-on.txt state
> >
> > > If it's a regression (heh :), please give alsa-info.sh output on
> > > older kernels.
> >
> > No, it's not a regression. At least not from 2.6.27.
> >
> > Please let me know if you need more information.
>
> One more thing. The headphones output actually works regardless of the
> led indicator status, so only the built-in speakers output seems to be
> affected.

How can you turn on/off LED? From your explanation, it seems not
directly bound with the audio mute.

Anyway, try model=mobile or model=laptop for snd-hda-intel module
option. Does the speaker work?


Takashi


\
 
 \ /
  Last update: 2009-06-30 16:37    [from the cache]
©2003-2011 Jasper Spaans