lkml.org 
[lkml]   [2009]   [Jun]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: iwl3945 in 2.6.31-rc0: ad-hoc mode broken?
From
Date
Hi Pavel,

On Fri, 2009-06-19 at 15:24 -0700, Pavel Machek wrote:
> I tried using ad-hoc mode (against t-mobile G1) on -rc0, and was
> unsuccessful -- never got dhcp. I had to reboot back to
> 2.6.30... Should I try it few more times or is something broken?

I have tried ad-hoc mode in 2.6.31-rc1
(52989765629e7d182b4f146050ebba0abf2cb0b7) and did not have issues. I
tested ad-hoc between 3945 (iwl3945) and 5100 (iwlagn), testing that
both are able to create the IBSS network and both are able to join
another IBSS network.

Do you get any errors? Is it just the dhcp that fails (does association
succeed?) mac80211 does have extra debugging for ad-hoc that can be
enabled with CONFIG_MAC80211_IBSS_DEBUG=y. Could you please try that?

>
> (Also wifi LED stopped working on x60, but that's older issue).

Is there a bug report for this?

Reinette




\
 
 \ /
  Last update: 2009-06-29 20:11    [W:0.076 / U:4.540 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site