lkml.org 
[lkml]   [2009]   [Jun]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 12/16] x86, mce: squash mce_intel.c into therm_throt.c
huang ying wrote:
>>
>> You can pull out "codes may not be shared" from therm_throt.c and
>> put it again into mce_intel.c (that was mce_intel_64.c). But I
>> believe it is not needed now, until another code is available.
>> Or you can rename therm_throt.c to thermal_intel.c or so for a while.
>
> I think thermal_intel.c is better.
>

Actually intel_thermal.c and intel_cmci.c would probably be the right
naming. The mce_ prefix for files in this directory is redundant; so
for vendor-specific features the vendor is the higher order organizing
factor.

-hpa

--
H. Peter Anvin, Intel Open Source Technology Center
I work for Intel. I don't speak on their behalf.



\
 
 \ /
  Last update: 2009-06-18 18:33    [W:0.076 / U:10.928 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site