[lkml]   [2009]   [Jun]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] gpiolib: Add gpio_detect, gpio_debounce and gpio_alt_func features to GPIOLIB
On Mon, Jun 15, 2009 at 10:50:23AM +0100, Ben Dooks wrote:
> On Mon, Jun 15, 2009 at 05:15:02PM +0800, Alek Du wrote:

> > * gpio_alt_func is to set pin as alternative function or GPIO.

> gpio_alt_func is feature creep, I don't really belive this is the
> best place to put it as it will be difficult to actually make this
> generic for all gpio platforms.

Since the proposed API just passes a value through to the driver for the
GPIO chip it looks generic enough - each chip can define whatever set of
constants it likes. I'd expect a large proportion of driver specific
APIs would end up just the same.

Given the number of manufacturers that don't use a separate term like
the PXA MFP for the alternative functions of their GPIOs it makes sense
to have a gpiolib API for this. Without one you end up having each
driver needing to add its own API, and since the pins are just referred
to as GPIOs in the documentation the API will have that in the name and
look like it ought to be connected with gpiolib.

 \ /
  Last update: 2009-06-15 12:05    [W:0.099 / U:4.180 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site