lkml.org 
[lkml]   [2009]   [May]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [TOMOYO] Add garbage collector support.
From
Date
James Morris wrote:
> > James, it is possible to apply below commits to security-testing-2.6#next ?
> > I get a lot of warning messages in my environment.
>
> Please elaborate.

Without commits

mm: pass correct mm when growing stack
Revert "kobject: don't block for each kobject_uevent".
x86: clean up old gcc warnings

I get compiler warnings

# make init/main.o
scripts/kconfig/conf -s arch/x86/Kconfig
CHK include/linux/version.h
CHK include/linux/utsrelease.h
SYMLINK include/asm -> include/asm-x86
CALL scripts/checksyscalls.sh
CC init/main.o
In file included from /usr/src/all/security-testing-2.6.git/arch/x86/include/asm/page.h:8,
from /usr/src/all/security-testing-2.6.git/arch/x86/include/asm/processor.h:18,
from include/linux/prefetch.h:14,
from include/linux/list.h:6,
from include/linux/module.h:9,
from init/main.c:13:
/usr/src/all/security-testing-2.6.git/arch/x86/include/asm/page_types.h:48: warning: parameter has incomplete type
/usr/src/all/security-testing-2.6.git/arch/x86/include/asm/page_types.h:50: warning: parameter has incomplete type

and runtime warnings

------------[ cut here ]------------
WARNING: at security/security.c:217 security_vm_enough_memory+0x9b/0xb0()
Hardware name: VMware Virtual Platform
Modules linked in: pcnet32 crc32
Pid: 3277, comm: khelper Not tainted 2.6.29 #3
Call Trace:
[<c015f400>] ? zap_locks+0x110/0x130
[<c015e5fd>] warn_slowpath+0x8d/0xf0
[<c019b2ec>] ? validate_chain+0x3fc/0x540
[<c019b2ec>] ? validate_chain+0x3fc/0x540
[<c019d79c>] ? __lock_acquire+0x29c/0x8b0
[<c019f159>] ? __lock_acquired+0x109/0x1c0
[<c035bbdb>] security_vm_enough_memory+0x9b/0xb0
[<c02089bb>] acct_stack_growth+0xcb/0x190
[<c0208ba1>] expand_downwards+0x121/0x1a0
[<c0208c3d>] expand_stack+0xd/0x10
[<c0208cdd>] find_extend_vma+0x9d/0x130
[<c01ff5d5>] __get_user_pages+0x95/0x6c0
[<c01ffc73>] get_user_pages+0x73/0x90
[<c0233cd8>] get_arg_page+0x48/0x130
[<c02342a5>] copy_strings+0x165/0x2f0
[<c02366ba>] do_execve+0x31a/0x900
[<c010252a>] sys_execve+0x5a/0xb0
[<c01040b4>] syscall_call+0x7/0xb
[<c010b624>] ? kernel_execve+0x24/0x30
[<c017ab73>] ? ____call_usermodehelper+0x103/0x190
[<c017aa70>] ? ____call_usermodehelper+0x0/0x190
[<c0104a73>] ? kernel_thread_helper+0x7/0x10
---[ end trace 636cdcc028137283 ]---

in my environment.

These commits are already in 2.6.30-rc4.
These warnings will disappear when security-testing-2.6#next is refreshed
using 2.6.30-rcX . But security-testing-2.6#next is using 2.6.29.
Thus, I wished these commits applied to security-testing-2.6#next
if there is no problem.


\
 
 \ /
  Last update: 2009-05-08 04:15    [W:0.061 / U:2.376 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site