[lkml]   [2009]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [FOR REVIEW, PATCH 2/2] introduce "struct wait_opts" to simplify do_wait() pathes
I like the idea just fine.  Drop the "w" on every field name.
If you want them to have a greppable uniqueness/prefix, use "wo_".
I'd go with a shorter name for the canonical pointer parameter,
like "w" or "wo".

It looks cleaner to me to keep the several args to do_wait() and have
it use a single initializer with = { .foo = a, .bar = b } syntax there.


 \ /
  Last update: 2009-05-06 22:13    [W:0.056 / U:0.112 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site