lkml.org 
[lkml]   [2009]   [May]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [my_cpu_ptr 1/5] Introduce my_cpu_ptr()
Christoph Lameter wrote:
> On Thu, 28 May 2009, Christoph Hellwig wrote:
>
>> On Thu, May 28, 2009 at 01:16:01PM +0930, Rusty Russell wrote:
>>> On Thu, 28 May 2009 03:16:59 am cl@linux-foundation.org wrote:
>>>> my_cpu_ptr(xx) = per_cpu_ptr(xx, smp_processor_id).
>>> I had this implemented earlier as as get_cpu_ptr()/__get_cpu_ptr(), to match
>>> get_cpu_var() / __get_cpu_var().
>>>
>>> But other than that nomenclature quibble, it looks fine!
>> my_ seems a very odd naming. We have a lot of this_cpu naming for the
>> current cpu i nthe ctree, so I would suggest sticking to that.
>
> So this_cpu is taken. I used THIS_CPU in earlier version
> but got complaints about uppercase use. Is
>
> this_cpu_ptr()
>
> and
>
> __this_cpu_ptr()
>
> ok?

Yeap, those look fine to me. Sans the renaming, the series generally
looks good but I didn't review each conversion.

For the first patch, Acked-by: Tejun Heo <tj@kernel.org>

Thanks.

--
tejun


\
 
 \ /
  Last update: 2009-05-29 11:51    [W:0.060 / U:5.748 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site