lkml.org 
[lkml]   [2009]   [May]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 1/3] clean up setup_per_zone_pages_min
    On Wed, 20 May 2009 11:21:29 +0100
    Mel Gorman <mel@csn.ul.ie> wrote:

    > On Wed, May 20, 2009 at 06:58:03PM +0900, Minchan Kim wrote:
    > > Hi, Mel.
    > >
    > > On Wed, 20 May 2009 09:54:16 +0100
    > > Mel Gorman <mel@csn.ul.ie> wrote:
    > >
    > > > On Wed, May 20, 2009 at 04:18:53PM +0900, Minchan Kim wrote:
    > > > >
    > > > > Mel changed zone->pages_[high/low/min] with zone->watermark array.
    > > > > So, setup_per_zone_pages_min also have to be changed.
    > > > >
    > > >
    > > > Just to be clear, this is a function renaming to match the new zone
    > > > field name, not something I missed. As the function changes min, low and
    > > > max, a better name might have been setup_per_zone_watermarks but whether
    > >
    > > At first, I thouht, too. But It's handle of min_free_kbytes.
    > > Documentation said, it's to compute a watermark[WMARK_MIN].
    > > I think many people already used that knob to contorl pages_min to keep the
    > > low pages.
    >
    > Which documentation?

    Documentation/sysctl/vm.txt - min_free_kbytes.

    > I'm looking at the function comment and see
    >
    > * setup_per_zone_pages_min - called when min_free_kbytes changes.
    > *
    > * Ensures that the pages_{min,low,high} values for each zone are set
    > * correctly with respect to min_free_kbytes.
    >
    > So, the values of all the watermarks are updated by that function depending
    > on what the new value of min_free_kbytes is. It is a bit wrong I suppose as
    > it missed memory hot-add
    >
    > setup_per_zone_pages_min - called when min_free_kbytes changes or when memory is hot-added

    God!. I changed this function's comments with memory hot plug.
    With my mistake, My patch 3/3 lost it.
    I will add comment about memory hotplug.

    Thanks for pointing me out. :)


    > >
    > > So, I determined function name is proper now.
    > > If setup_per_zone_watermark is better than it, we also have to change with
    > > documentation.
    > >
    > > > you go with that name or not, this is better than what is there so;
    > > >
    > > > Acked-by: Mel Gorman <mel@csn.ul.ie>
    > >
    > >
    > > --
    > > Kinds Regards
    > > Minchan Kim
    > >
    >
    > --
    > Mel Gorman
    > Part-time Phd Student Linux Technology Center
    > University of Limerick IBM Dublin Software Lab


    --
    Kinds Regards
    Minchan Kim


    \
     
     \ /
      Last update: 2009-05-20 12:35    [W:0.024 / U:125.176 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site