lkml.org 
[lkml]   [2009]   [May]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] IO Controller: Add per-device weight and ioprio_class handling
Vivek Goyal wrote:
> On Wed, May 13, 2009 at 10:00:21AM +0800, Gui Jianfeng wrote:
>
> [..]
>> @@ -2137,7 +2366,7 @@ void elv_fq_unset_request_ioq(struct request_queue *q, struct request *rq)
>> void bfq_init_entity(struct io_entity *entity, struct io_group *iog)
>> {
>> entity->ioprio = entity->new_ioprio;
>> - entity->weight = entity->new_weight;
>> + entity->weight = entity->new_weigh;
>> entity->ioprio_class = entity->new_ioprio_class;
>> entity->sched_data = &iog->sched_data;
>> }
>> diff --git a/block/elevator-fq.h b/block/elevator-fq.h
>> index db3a347..0407633 100644
>> --- a/block/elevator-fq.h
>> +++ b/block/elevator-fq.h
>> @@ -253,6 +253,14 @@ struct io_group {
>> #endif
>> };
>>
>> +struct policy_node {
>
> Would "io_policy_node" be better?

Sure

>
>> + struct list_head node;
>> + char dev_name[32];
>> + void *key;
>> + unsigned long weight;
>> + unsigned long ioprio_class;
>> +};
>> +
>> /**
>> * struct bfqio_cgroup - bfq cgroup data structure.
>> * @css: subsystem state for bfq in the containing cgroup.
>> @@ -269,6 +277,9 @@ struct io_cgroup {
>>
>> unsigned long weight, ioprio_class;
>>
>> + /* list of policy_node */
>> + struct list_head list;
>> +
>
> How about "struct list_head policy_list" or "struct list_head io_policy"?

OK

--
Regards
Gui Jianfeng



\
 
 \ /
  Last update: 2009-05-14 03:05    [from the cache]
©2003-2011 Jasper Spaans