lkml.org 
[lkml]   [2009]   [May]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH #upstream-fixes] libata: fix attach error handling
Tejun Heo wrote:
> New device attach path in ata_eh_revalidate_and_attach() is divided
> into two separate loops because ATA requires IDENTIFY to be issued to
> slave first while the user expects to see device probe messages from
> the master device. new_mask is used to track which devices are the
> new ones between the first loop and the second.
>
> This usually works well but if an error occurs during configuration
> stage, ata_dev_revalidate_and_attach() returns with error code and
> forgets new_mask. On the retry run, dev->class is set and new_mask
> for the device is clear, so the device just gets revalidated and thus
> ends up skipping post-configuration procedure including scheduling of
> SCSI_HOTPLUG for the device. When this occurs, ATA part of probing
> works fine but SCSI probing usually doesn't happen and makes the
> device unreachable.
>
> The behavior has been around for a very long time but it has been
> uncovered with the recent addition of 1_5_GBPS horkage which uses
> -EAGAIN return value from ata_dev_configure() to restart the probing
> sequence after forcing cable speed.
>
> This can be fixed by making sure dev->class is permanently set only
> after all configurations are successfully complete. Fix it.
>
> Signed-off-by: Tejun Heo <tj@kernel.org>
> Reported-by: Tim Connors <tconnors+linuxkml@astro.swin.edu.au>
> ---
> drivers/ata/libata-eh.c | 21 +++++++++++++++++----
> 1 file changed, 17 insertions(+), 4 deletions(-)

applied




\
 
 \ /
  Last update: 2009-05-11 20:37    [W:0.039 / U:31.196 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site