lkml.org 
[lkml]   [2009]   [May]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 03/14] ide-atapi: switch to rq->resid_len
On Sun, May 10, 2009 at 11:32:32PM +0200, Bartlomiej Zolnierkiewicz wrote:
> On Saturday 09 May 2009 09:45:23 Borislav Petkov wrote:
> > Now that we have rq->resid_len, use it to account partial completion
> > amount during the lifetime of an rq, decrementing it on each successful
> > transfer. As a result, get rid of now unused pc->xferred.
> >
> > While at it, remove noisy debug call in ide_prep_sense.
> >
> > Signed-off-by: Borislav Petkov <petkovbb@gmail.com>
> > ---
> > drivers/ide/ide-atapi.c | 17 ++++++++---------
> > drivers/ide/ide-tape.c | 11 ++++-------
> > include/linux/ide.h | 2 --
> > 3 files changed, 12 insertions(+), 18 deletions(-)
>
> WARNING: line over 80 characters
> #118: FILE: drivers/ide/ide-tape.c:370:
> + int blocks = (blk_rq_bytes(rq) - rq->resid_len) / tape->blk_size;

No worries, I haven't forgotten the checkpatch thing but the line is
81 chars and I just didn't want to split it because of _one_ char. The
benefit of readability of having it on one line should be more important
than one stupid static rule. I think we should relax it if enforcing it
worsens readability...

int blocks = (blk_rq_bytes(rq) - rq->resid_len) /
tape->blk_size;

Now this looks awful, IMHO. I'd much rather not listen to checkpatch
here.

--
Regards/Gruss,
Boris.


\
 
 \ /
  Last update: 2009-05-11 09:27    [from the cache]
©2003-2011 Jasper Spaans