[lkml]   [2009]   [Apr]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [GIT *] intel-iommu updates for 2.6.30 (second batch)
On Tue, 2009-04-07 at 07:37 +0200, Ingo Molnar wrote:
> I suspect these bits are the ones that broke the upstream build:
> drivers/pci/dmar.c:47: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
> ‘__attribute__’ before ‘dmar_tbl_size’
> drivers/pci/dmar.c:62: warning: ‘struct acpi_dmar_device_scope’
> declared inside parameter list
> drivers/pci/dmar.c:62: warning: its scope is only this definition or
> declaration, which is probably not what you want

Yeah, <acpi/acpi.h> was being included implicitly for me, but certain
configs don't do that. Alexander Beregalov sent a patch for that, which
I added to my tree before Linus pulled it.

Commit 46f06b72378d3187f0d12f7a60d020676bfbf332 is the fix.

David Woodhouse Open Source Technology Centre Intel Corporation

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2009-04-07 07:49    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean