lkml.org 
[lkml]   [2009]   [Apr]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 18/29] x86/perfcounters: rename cpuc->active_mask

    * Robert Richter <robert.richter@amd.com> wrote:

    > This is to have a consistent naming scheme with cpuc->used.
    >
    > Signed-off-by: Robert Richter <robert.richter@amd.com>
    > ---
    > arch/x86/kernel/cpu/perf_counter.c | 10 +++++-----
    > 1 files changed, 5 insertions(+), 5 deletions(-)
    >
    > diff --git a/arch/x86/kernel/cpu/perf_counter.c b/arch/x86/kernel/cpu/perf_counter.c
    > index 3f3ae47..9ec51a6 100644
    > --- a/arch/x86/kernel/cpu/perf_counter.c
    > +++ b/arch/x86/kernel/cpu/perf_counter.c
    > @@ -29,9 +29,9 @@ static u64 perf_counter_mask __read_mostly;
    > struct cpu_hw_counters {
    > struct perf_counter *counters[X86_PMC_IDX_MAX];
    > unsigned long used[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
    > + unsigned long active[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
    > unsigned long interrupts;
    > u64 throttle_ctrl;
    > - unsigned long active_mask[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
    > int enabled;

    better would be to change ->used to ->used_mask. That makes it sure
    nobody does this typo:

    if (cpuc->used)

    it's a lot harder to typo this:

    if (cpuc->used_mask)

    Ingo


    \
     
     \ /
      Last update: 2009-04-29 13:27    [W:3.959 / U:0.004 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site