lkml.org 
[lkml]   [2009]   [Apr]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 fixed] e100: do not go D3 in shutdown unless system is powering off
On Tue, Apr 21, 2009 at 10:46:19PM -0700, Jeff Kirsher wrote:
> On Tue, Apr 21, 2009 at 9:38 PM, Thadeu Lima de Souza Cascardo
> <cascardo@holoscopio.com> wrote:
> > After experimenting with kexec with the last merges after 2.6.29, I've
> > had some problems when probing e100. It would not read the eeprom. After
> > some bisects, I realized this has been like that since forever (at least
> > 2.6.18). The problem is that shutdown is doing the same thing that
> > suspend does and puts the device in D3 state. I couldn't find a way to
> > get the device back to a sane state in the probe function. So, based on
> > some similar patches from Rafael J. Wysocki for e1000, e1000e and ixgbe,
> > I wrote this one for e100.
> >
> > Signed-off-by: Thadeu Lima de Souza Cascardo <cascardo@holoscopio.com>
> > ---
>
> Thanks, I will add it to my queue of patches for e100.
>
> Also, just FYI, Auke is no longer a maintainer for
> e100/e1000/e1000e/igb/ixgb/ixgbe devices, so I have removed him from
> the thread.
>
> --
> Cheers,
> Jeff

Perhaps, Rafael should be mentioned in a Reviewed-by? As well as you if
you did review it? I guess a Tested-by and Reported-by me is overkill,
right? :-)
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2009-04-22 21:41    [from the cache]
©2003-2011 Jasper Spaans