lkml.org 
[lkml]   [2009]   [Apr]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: No sound with 2.6.29-git5 vanilla through 2.6.30-rc1-git1 on hda-intel (F10 kernel has sound)
From
On Tue, Apr 14, 2009 at 4:30 PM, Takashi Iwai <tiwai@suse.de> wrote:
> At Thu, 9 Apr 2009 16:32:48 +0200,
> Alessandro Suardi wrote:
>>
>> My cursed Dell E6400 is turning up more issues I recall ever seeing
>>  in my 13.5 years of Linuxing -- wireless is unsupported in vanilla,
>>  X/VT switching moans, MTRR still complains, microcode WARNs on
>>  boot - and the joys of 64-bit Firefox with gnash and IcedTea...
>>
>> And now, sound only works in Fedora 10 with the F10 kernel, that is:
>>
>> 2.6.27.21-170.2.56.fc10.x86_64
>>
>>  but not with any vanilla kernel I built. So it might be me, of course; but
>>  the ALSA modules seem the same in the two kernels - where applicable
>>  (recent kernels have a hda-intel-codec module that doesn't seem to be
>>  loaded in the F10 kernel).
>
> snd-hda-codec-* modules are loaded automatically from snd-hda-intel.
> Do you have snd-hda-codec-idt module?
> It's enabled via CONFIG_SND_HDA_CODEC_SIGMATEL=y.
>
>
> Takashi

Thanks Takashi -

no, I haven't that one; am I supposed to set to Y all codecs under the
SND_HDA_INTEL tab ? And if not, how do I guess which one[s] ?

I wouldn't have known about SIGMATEL rather than, say, CONEXANT
(which I didn't enable) or INTELHDMI (which I did)...

--alessandro

"Sun keeps rising in the west / I keep on waking fully confused"

(The Replacements, "Within Your Reach")
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2009-04-15 15:37    [W:0.144 / U:0.196 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site