lkml.org 
[lkml]   [2009]   [Apr]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 00/30] C/R OpenVZ/Virtuozzo style
On Tue, Apr 14, 2009 at 03:44:20PM +0200, Ingo Molnar wrote:
>
> * Alexey Dobriyan <adobriyan@gmail.com> wrote:
>
> > On Mon, Apr 13, 2009 at 11:39:51AM -0700, Linus Torvalds wrote:
> > >
> > >
> > > On Mon, 13 Apr 2009, Alexey Dobriyan wrote:
> > > >
> > > > Well, in OpenVZ everything is in kernel/cpt/ and prefixed with "cpt_"
> > > > and "rst_".
> > >
> > > So?
> > >
> > > We're not merging OpenVZ code _either_.
> >
> > This is to give example of other prefixes: cpt_ and rst_
> > Are they fine?
>
> Not really. 'rst' can be easily mistaken for 'reset' and neither
> really tells me at a glance what they do. They are also quite
> tongue-twisters.
>
> See my namespace analysis and suggestions from yesterday for a
> proper naming scheme.
>
> The key i believe is to move away from this singular 'the world is
> all about checkpoint and restore', and move it to a IMHO clearer
> state_*() type of naming which really isolates all these kernel
> state save/restore management APIs from other kernel APIs. (See my
> mail from yesterday for details.)
>
> kstate_*() would be another, perhaps even clearer naming scheme.
> I.e.:
>
> kstate_checkpoint_XYZ()
> kstate_restore_XYZ()
> kstate_collect_XYZ()
> kstate_dump_XYZ()
> kstate_image_XYZ()
> ...
>
> Just _look_ at them - they are expressive at a glance, and
> reasonably short. That is the kind of first-time impression
> we need, not a 'wtf?' moment.
>
> I just checked, there's zero hits on "git grep \<kstate_" in the
> kernel, so it's a pristine namespace. IMHO, go wild ...

Need to try it for real.

One minor nit. This kstate_ doesn't include quite a noticable of
in-kernel state. For example, task readahead state isn't relevant
to C/R at all. It's state but irrelevant state.


\
 
 \ /
  Last update: 2009-04-14 18:55    [W:0.106 / U:5.720 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site