lkml.org 
[lkml]   [2009]   [Apr]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH] vmscan: memcg needs may_swap (Re: [patch] vmscan: rename sc.may_swap to may_unmap)
    On Tue, Mar 31, 2009 at 10:48:32AM +0900, KOSAKI Motohiro wrote:
    > > > Sorry for too late response.
    > > > I don't know memcg well.
    > > >
    > > > The memcg managed to use may_swap well with global page reclaim until now.
    > > > I think that was because may_swap can represent both meaning.
    > > > Do we need each variables really ?
    > > >
    > > > How about using union variable ?
    > >
    > > or Just removing one of them ?
    >
    > I hope all may_unmap user convert to using may_swap.
    > may_swap is more efficient and cleaner meaning.

    How about making may_swap mean the following:

    @@ -642,6 +639,8 @@ static unsigned long shrink_page_list(st
    * Try to allocate it some swap space here.
    */
    if (PageAnon(page) && !PageSwapCache(page)) {
    + if (!sc->map_swap)
    + goto keep_locked;
    if (!(sc->gfp_mask & __GFP_IO))
    goto keep_locked;
    if (!add_to_swap(page))

    try_to_free_pages() always sets it.

    try_to_free_mem_cgroup_pages() sets it depending on whether it really
    wants swapping, and only swapping, right? But the above would still
    reclaim already swapped anon pages and I don't know the memory
    controller.

    balance_pgdat() always sets it.

    __zone_reclaim() sets it depending on zone_reclaim_mode. The
    RECLAIM_SWAP bit of this field and its documentation in
    Documentation/sysctl/vm.txt suggests it also really only means swap.

    shrink_all_memory() would be the sole user of may_unmap because it
    really wants to eat cache first. But this could be figured out on a
    different occasion.

    Hannes


    \
     
     \ /
      Last update: 2009-04-01 06:15    [W:3.408 / U:0.484 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site