lkml.org 
[lkml]   [2009]   [Mar]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG] Loading both ehci-hcd and uhci-hcd drivers causes my printer to fail
On Mon, 9 Mar 2009, Maxim Levitsky wrote:

> > Is your printer connected directly to the computer, or does it go
> > through a hub? (If it is connected directly then EHCI_TT_NEWSCHED
> > should not affect it at all.)
> >
> > If it does go through a hub, does it behave better when you attach it
> > directly?
> >
> > Alan Stern
> >
> No, it is connected directly.
> Just tried 'bad' driver, and firmware upload failed
>
> Do you mean that CONFIG_USB_EHCI_TT_NEWSCHED doesn't affect the driver
> at all when no hub is presented?

That's right. Transaction Translators (TTs) live inside hubs. If you
don't use a hub then the TT code never runs.

> Btw, at least according to lsusb -t, there are no internal hubs in the
> printer.

What does /proc/bus/usb/devices say?

> But it can be a coincidence, it seems that with 'bad' driver printer
> works 'better' to as it failed back few days ago much more often, maybe
> cable is bad, don't know, but according to the web these printers
> 1018/1020.. have usb problems, there is even a readme for that in
> foo2zjz
>
> I try to use the 'good' driver
> (without CONFIG_USB_EHCI_TT_NEWSCHED) for some time.

Please don't forget to collect usbmon traces when the problem occurs.

Alan Stern



\
 
 \ /
  Last update: 2009-03-09 17:17    [W:0.038 / U:9.392 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site