lkml.org 
[lkml]   [2009]   [Mar]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: Resume after hibernation regression in 2.6.29
    Date
    On Thursday 26 March 2009 20:18:40 Pavel Machek wrote:
    > On Thu 2009-03-26 19:20:32, Tvrtko A. Ursulin wrote:
    > > Hi guys,
    > > I have been running custom compiled 2.6.28.7 in OpenSUSE 11.1 and using
    > > hiberation/resume daily as configured by the distro. Yesterday I upgraded
    > > to 2.6.29 (make oldconfig from 2.6.28.7, attached) and after resume
    > > networking (at least) does not work. Reboot at this point takes very long
    > > because of timeouts on CIFS and whatelse.
    > >
    > > Below is how /var/log/messagess looks for one cycle
    > > (hibernate-resume-reboot) and I am also attaching kernel config and
    > > /var/log/pm-suspend.log.
    > >
    > > You will probably notice evil nvidia.ko in there but don't panic, it all
    > > happens without it as well. Tested from runlevel 3 and by running
    > > pm-hibernate. After resume from that NIC LEDs were off. I
    > > tried /etc/init.d/network restart but that hung so I ^C and tried rmmod
    > > forcedeth && modprobe forcedeth && ifup eth0 and after some time network
    > > went live again. Haven't had time to test further though, so this is all
    > > pretty rough.
    >
    > Ok, can you try to rmmod forcedeth before hibernation, then insmod it
    > after resume?

    Sure, after insmod and /etc/init.d/network start following resume network was
    fine. Guess I could kludge that sequence into pm scripts somehow but would
    rather avoid that since it slows down the cycle and would make scripts
    non-stock.

    Tvrtko


    \
     
     \ /
      Last update: 2009-03-26 22:09    [W:0.023 / U:30.148 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site