lkml.org 
[lkml]   [2009]   [Mar]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH -mm 1/6] slab: introduce __kfree_rcu
From
Date
On Tue, 2009-03-03 at 21:44 +0800, Lai Jiangshan wrote:
> Introduce __kfree_rcu() for kfree_rcu()
>
> We can calculate the object poiter from a poiter inside this
> object in slab.c, so we can use a portion_to_obj() to instead
> various container_of() for rcu callback and free the object.
>
> Signed-off-by: Lai Jiangshan <laijs@cn.fujitsu.com>
> ---
> diff --git a/mm/slab.c b/mm/slab.c
> index 4d00855..a067d3f 100644
> --- a/mm/slab.c
> +++ b/mm/slab.c
> @@ -634,6 +634,17 @@ static inline unsigned int obj_to_index(const struct kmem_cache *cache,
> return reciprocal_divide(offset, cache->reciprocal_buffer_size);
> }
>
> +static inline void *portion_to_obj(void *portion)
> +{
> + struct page *page = virt_to_head_page(portion);
> + struct slab *slab = page_get_slab(page);
> + struct kmem_cache *cache = page_get_cache(page);
> + unsigned int offset = portion - slab->s_mem;
> + unsigned int index = offset / cache->buffer_size;
> +
> + return index_to_obj(cache, slab, index);
> +}

A minor nit: I think this would be more readable if you separated
variable declarations from the initializations. Also, you can probably
drop the inline from the function declaration and let GCC decide what to
do.



\
 
 \ /
  Last update: 2009-03-23 08:51    [from the cache]
©2003-2011 Jasper Spaans