lkml.org 
[lkml]   [2009]   [Mar]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: SquashFS io errors - zlib_inflate tried to decompress too much data
From
On Sat, Mar 21, 2009 at 11:33, Bruno Prémont <bonbons@linux-vserver.org> wrote:
>
> With 2.6.29-rc7-git5 (x86, 32bit) I get the following errors on assumed
> correct squashfs images (generated with mksquashfs from CVS, dated
> 2009-03-14)
>
> [ 3481.692558] SQUASHFS error: zlib_inflate tried to decompress too much data, expected 8192 bytes.  Zlib data probably corrupt
> [ 3481.692571] SQUASHFS error: squashfs_read_data failed to read block 0x29375e0
> [ 3481.692579] SQUASHFS error: Unable to read metadata cache entry [29375e0]
> [ 3481.692586] SQUASHFS error: Unable to read inode 0x6a04a05ed
>
> The same happens on 2.6.28.8 with all squashfs patches from 2.6.29-rc8
> applied to it (x86, 64bit).

A fix for this has entered mainline:

commit 363911d027d1de1c6df79eb3f487f5476b9619f4
Author: Phillip Lougher <phillip@lougher.demon.co.uk>
Date:   Thu Mar 12 03:23:48 2009 +0000

    Squashfs: Valid filesystems are flagged as bad by the corrupted fs patch

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
   -- Linus Torvalds
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2009-03-21 13:13    [W:0.111 / U:7.076 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site