lkml.org 
[lkml]   [2009]   [Mar]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: oops in tracepoint_update_probe_range()
From
Date
On Thu, 2009-03-19 at 09:22 -0400, Mathieu Desnoyers wrote:
> * Ingo Molnar (mingo@elte.hu) wrote:
> >
> > * Lai Jiangshan <laijs@cn.fujitsu.com> wrote:
> >
> > > Ingo Molnar wrote:
> > > > * Jaswinder Singh Rajput <jaswinder@kernel.org> wrote:
> > > >
> > > >> Good: f4c3c4cdb1de232
> > > >> Bad : 1e08816af0bc345
> > > >>
> > > >> Config:
> > > >> http://userweb.kernel.org/~jaswinder/oops_20090318/config-hpdv5-tip-bad-20090318
> > > >>
> > > >> oops:
> > > >> http://userweb.kernel.org/~jaswinder/oops_20090318/oops_page1.jpg
> > > >> http://userweb.kernel.org/~jaswinder/oops_20090318/oops_page2.jpg
> > > >> http://userweb.kernel.org/~jaswinder/oops_20090318/oops_page3.jpg
> > > >> http://userweb.kernel.org/~jaswinder/oops_20090318/oops_page4.jpg
> > > >>
> > > >> <freeze>
> > > >
> > > > Steve, Frederic - the crashes above are in:
> > > >
> > > > tracepoint_update_probe_range()
> > > >
> > > > in a modular kernel apparently.
> > > >
> > > >
> > >
>
> Jaswinder : maybe you have old modules in your /lib/modules/`uname -r`
> directory which have the correct version, but the wrong module.h header ?
>

yes, it was having old modules, after deleting old modules.

[root@hpdv5 linux-2.6-tip]# make modules_install
INSTALL arch/x86/kernel/test_nx.ko
INSTALL drivers/hid/hid-dummy.ko
INSTALL drivers/scsi/scsi_wait_scan.ko
DEPMOD 2.6.29-rc8-tip
[root@hpdv5 jaswinder-git]# /sbin/mkinitrd /boot/initrd-2.6-tip.img 2.6.29-rc8-tip
[root@hpdv5 linux-2.6-tip]#


By following above steps, I get rid of oops, and here is my lsmod:
[jaswinder@hpdv5]$ /sbin/lsmod
Module Size Used by
[jaswinder@hpdv5]$

--
JSR



\
 
 \ /
  Last update: 2009-03-19 16:47    [from the cache]
©2003-2011 Jasper Spaans