lkml.org 
[lkml]   [2009]   [Feb]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 01/15] ide: include <asm/ide.h> only when needed
From
On Sat, 07 Feb 2009 01:03:59 +0300, Sergei Shtylyov <sshtylyov@ru.mvista.com> wrote:
> > config CONFIG_IDE_BE_IO
> > bool
>
> If it was that simple... Normally the BE case gets handled automagically
> (moreover, there is MIPS option that additionally controls I/O and memory
> space byte swapping). The case we have to address for TX493x is actually where
> the usual magic fails (or actually the code just doesn't want to use that
> option). So this doesn't look like a good name to me...

Well, for TX493x (MIPS), we have CONFIG_SWAP_IO_SPACE for big endian
and it works fine for PCI-IDE host controllers. For SoC internal
controllers, no swapping is needed for both endian, thus custom tp_ops
is needed only for big endian.

So ... IDE_BE_IO looks actually not best name for this case. It is
IDE_RAW_IO or something. But IDE_RAW_IO might not fit for other
cases. IDE_SWAPPED_IO? Any other good name?

---
Atsushi Nemoto


\
 
 \ /
  Last update: 2009-02-07 16:37    [from the cache]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and my Meterkast|Read the blog