lkml.org 
[lkml]   [2009]   [Feb]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/1] trace: use the more accurate parameter.

On Wed, 11 Feb 2009, Ingo Molnar wrote:

>
> * Frederic Weisbecker <fweisbec@gmail.com> wrote:
>
> > On Mon, Feb 09, 2009 at 07:30:04PM -0500, Wenji Huang wrote:
> > > Pass tsk to __update_max_tr instead of current to avoid latent hazard.
> > >
> > > Impact: clean up
> > >
> > > Signed-off-by: Wenji Huang <wenji.huang@oracle.com>
> > > ---
> > > kernel/trace/trace.c | 2 +-
> > > 1 files changed, 1 insertions(+), 1 deletions(-)
> > >
> > > diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
> > > index 5b1e9a9..c1592f1 100644
> > > --- a/kernel/trace/trace.c
> > > +++ b/kernel/trace/trace.c
> > > @@ -335,7 +335,7 @@ __update_max_tr(struct trace_array *tr, struct task_struct *tsk, int cpu)
> > > data->rt_priority = tsk->rt_priority;
> > >
> > > /* record this tasks comm */
> > > - tracing_record_cmdline(current);
> > > + tracing_record_cmdline(tsk);
> > > }
> >
> >
> > Indeed. At this stage, tsk is the next task in the middle of a context
> > switch. So I guess current is right, but this is more proper to use tsk.
>
> Rename it to 'next' then please.

I'm sorry, I missed this comment, and only notice it because of Wenji's
latest patches.

For the __update_max_tr used by irqsoff, this is not the case. The
update_max_tr is just to make a snapshot of the latest max. The
irq/preempt latency tracers do not use the sched switch to record comms,
especially since it only cares when a new max happens. There is no concept
of a 'next' task.

I think the proper name is 'task'.

-- Steve



\
 
 \ /
  Last update: 2009-02-13 06:59    [W:0.408 / U:0.072 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site