lkml.org 
[lkml]   [2009]   [Dec]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] uvcvideo: add another YUYV format GUID
On 04.12.2009 05:59, Justin P. Mattock wrote:
> On 12/03/09 18:05, Daniel Ritz wrote:
>> Hi Laurent
>>
>> On Thu, 2009-12-03 at 21:15 +0100, Laurent Pinchart wrote:
>>> Hi Daniel,
>>>
>>> On Wednesday 02 December 2009 00:48:44 Daniel Ritz wrote:
>>>> For some unknown reason, on a MacBookPro5,3 the iSight
>>> Could you please send me the output of lsusb -v both with the correct and
>>> wrong GUID ?
>> sure. i attached three files:
>> isight-good.txt, isight-bad.txt, isight-good2.txt
>>
>> this is three reboots in a row from like 10 minutes ago. the first
>> boot into linux was actually rebooting from OSX...first cold boot
>> today directly into linux had the right GUID.
>>
>>>> _sometimes_ report a different video format GUID.
>>> Sometimes only ? Now that's weird. Is that completely random ?
>> yes, sometimes only. it seems to be related to reboots, but i don't
>> know what exactly triggers it. rmmod/modprobe doesn't trigger it.
>> also, when the wrong GUID is reported, the only way of fixing it is
>> to reboot. it really is just the GUID. even when the wrong one is
>> reported, the device works just fine.
>>
>> i started with a plain ubuntu 9.10, kernel 2.6.31 which was supposed
>> to fail, so i upgraded to a 2.6.32-rc8 to fix the iSight and some other
>> things, just to see it fail again. a reboot later and it worked, some
>> time and reboot later it failed again...
>>
>> rgds
>> -daniel
>>
>>>> This patch add the other (wrong) GUID to the format table, making the iSight
>>>> work always w/o other problems.
>>>>
>>>> What it should report: 32595559-0000-0010-8000-00aa00389b71
>>>> What it often reports: 32595559-0000-0010-8000-000000389b71
>>>>
>>>> Signed-off-by: Daniel Ritz<daniel.ritz@gmx.ch>
>>> --
>>> Regards,
>>>
>>> Laurent Pinchart
>
> I get weiredness whenever
> I shutdown the machine and then boot.
> If I boot, then reboot things work.
>

interesting...does my little patch work for you as well?

thanks
-daniel

> Justin P. Mattock
>



\
 
 \ /
  Last update: 2009-12-08 16:07    [W:0.075 / U:6.732 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site