lkml.org 
[lkml]   [2009]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.31 -> 2.6.32 Sound and video regressions
On Sat, 05 Dec 2009 23:44:55 +0000
Darren Salt <linux@youmustbejoking.demon.co.uk> wrote:

> I demand that Andy Lutomirski may or may not have written...
>
> > Emmanuel Benisty wrote:
> [snip]
> >> I just wanted to report 2 regressions I am having now with 2.6.32.
> >> Video
> >> Screen is flickering/glitching like crazy in X. It happens whether
> >> randomly or when conky is refreshed, when the mouse cursor moves
> >> and like hell when a page is loading in the browser. Not so easy to
> >> describe this issue.
> [snip]
>
> > That sounds like FIFO underruns, which (I think) were introduced
> > when self-refresh was enabled but should have been fixed. I
> > personally have no clue how to fix them, but if you told the Intel
> > people what kind of chip you have (lspci output), they can probably
> > fix it.
>
> It also sounds like what I'm seeing on my EeePC 901. It only happens
> after resume, which makes STR a little less than useful; the display
> will, sooner or later, show a single colour (which is, presumably,
> the result of a display engine hang, as described in the comment
> immediately before intel_calculate_wm) and, seemingly, be stuck like
> that until power-off or reboot.
>
> Whether it *is* the same problem, I couldn't say.
>
> Needless to say, this problem goes away if I disable KMS.

Arg, there are a few reports of this now, but I haven't been able to
reproduce it. I'll try harder... (FYI the upstream
bugs.freedesktop.org # for it is 24314).

--
Jesse Barnes, Intel Open Source Technology Center


\
 
 \ /
  Last update: 2009-12-07 02:43    [W:0.068 / U:28.196 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site