lkml.org 
[lkml]   [2009]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectREGRESSION for RT2561/RT61 in 2.6.32
Sorry for the late notice; I haven't tried running new kernels on this 
computer in a long time.

When I use 2.6.32 (or indeed 2.6.32-rc1), it works fine up until the
point where the wireless card is ifconfig'ed. Then not long afterward
(a few seconds to a minute) the system hangs.

# lspci -vv -s d.0
00:0d.0 Network controller: RaLink RT2561/RT61 802.11g PCI
Subsystem: Linksys WMP54G ver 4.1
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 11
Region 0: Memory at cfff0000 (32-bit, non-prefetchable) [size=32K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Kernel driver in use: rt61pci
Kernel modules: rt61pci
While the system is hung, Alt-SysRq-keys still work but nothing else
shows up when I type (using a VT console, not X). However I don't know
what debugging to do or what to look for.

Under 2.6.31 everything works okay.

Any help appreciated,

Alan Stern



\
 
 \ /
  Last update: 2009-12-06 23:15    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site