lkml.org 
[lkml]   [2009]   [Dec]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 1/4] vmscan: more simplify shrink_inactive_list()
Date
> This patch depend on "vmscan : simplify code" patch (written by Huang Shijie)
>
> =========================================
> Now, max_scan of shrink_inactive_list() is always passed less than
> SWAP_CLUSTER_MAX. then, we can remove scanning pages loop in it.
>
> detail
> - remove "while (nr_scanned < max_scan)" loop
> - remove nr_freed variable (now, we use nr_reclaimed directly)
> - remove nr_scan variable (now, we use nr_scanned directly)
> - rename max_scan to nr_to_scan
> - pass nr_to_scan into isolate_pages() directly instead
> using SWAP_CLUSTER_MAX

Andrew, please don't pick up this patch series awhile. I and some vmscan
folks are working on fixing Larry's AIM7 problem. it is important than this
and it might makes conflict against this.

I'll rebase this patch series awhile after.





\
 
 \ /
  Last update: 2009-12-04 09:29    [W:0.117 / U:11.208 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site