[lkml]   [2009]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: 2.6.31-rc9 kernel BUG and mvsas
On Thu, Dec 3, 2009 at 9:17 PM, Mikael Abrahamsson <> wrote:
> On Wed, 4 Nov 2009, Andre Tomt wrote:
>> Identical issues with the AOC-SASLP-MV8 card with 8 Seagate Barracuda
>> 7200.11 1.5TB drives using the mvsas driver. Creating a md raid array seems
>> to trigger it nearly instantly, however other loads do not trigger it
>> as fast (if at all, only tested briefly with paralell dd).
> Would just like to chime in with a "me too" on this. I've tried both ubuntu
> 9.10 kernel (2.6.31) and their 10.04 pre-alpha (guess it's 2.6.32-rc8) and
> mvsas + AOC-SASLP-MV8 is pretty much unusable. If I start md creation it
> stalls immediately and gets nowhere, last time I tried it md claimed it had
> written 160 blocks then it stalled (all drive LEDs on the controller is
> constantly lit).
> If I boot without drives and then hot-plug the drives, it immediately
> oops:es.
> Any code/fixes I can try, this is a lab machine so I can easily do whatever
> needed with it...


I had a bit of trouble finding some patches that were released by Andy Yan at
Marvell on November 9th, so here is a link:


I haven't tried these myself, but I believe that mr. Fjellstrom tried, with

Note to the lists - the patches weren't properly construction for inclusion in
the kernel. If the outstanding issues could be fixed, this would be a boon to
the open-soure community as these cards are very good value for money. They
have been recommended for use on OpenSolaris by one of Stanford's ZFS
admins, which indicates their quality to be very much acceptable.

-- Kristleifur

 \ /
  Last update: 2009-12-03 22:39    [W:0.140 / U:4.652 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site