[lkml]   [2009]   [Dec]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: trace/events: DECLARE vs DEFINE semantic
    Mathieu Desnoyers wrote:
    > In addition, I wonder if we should rename "CREATE_TRACE_POINTS" to
    > something more suitable while we are here ? Basically, it will affect
    > all TRACE_CLASS/TRACE_CLASS_EVENT/TRACE_EVENT from headers included
    > after it's defined.

    Agreed, CREATE_TRACE_POINTS is a bit irritating thing :-(

    For example, if we call tracepoints defined in same-header on
    several different files, we need to check other people have
    already defined CREATE_TRACE_POINTS on another file, because
    CREATE_TRACE_POINTS must be used once for each header...

    So, how about introducing a c file which is only for defining
    tracepoints for kernel parts ? or defining tracepoints in
    kernel at the beginning of kernel/tracepoint.c ? (and don't
    touch tracepoints in modules)


    #include <trace/events/sched.h>
    #include <trace/events/...>

    #include <trace/events/sched.h> /* Just include events header */
    @fs/ext4/super.c (no change, since it can be module)
    #include <trace/events/ext4.h>


    Thank you,

    Masami Hiramatsu

    Software Engineer
    Hitachi Computer Products (America), Inc.
    Software Solutions Division


     \ /
      Last update: 2009-12-03 05:01    [from the cache]
    ©2003-2014 Jasper Spaans. hosted at Digital Ocean