[lkml]   [2009]   [Dec]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC mm][PATCH 4/5] add a lowmem check function
On Thu, 10 Dec 2009 11:59:11 -0600 (CST)
Christoph Lameter <> wrote:

> On Thu, 10 Dec 2009, KAMEZAWA Hiroyuki wrote:
> > This patch adds an integer lowmem_zone, which is initialized to -1.
> > If zone_idx(zone) <= lowmem_zone, the zone is lowmem.
> There is already a policy_zone in mempolicy.h. lowmem is if the zone
> number is lower than policy_zone. Can we avoid adding another zone
> limiter?
My previous version (one month ago) does that. In this set, I tried to use
unified approach for all CONFIG_NUMA/HIGHMEM/flat ones.

Hmm, How about adding following kind of patch after this

#define policy_zone (lowmem_zone + 1)

and remove policy_zone ? I think the name of "policy_zone" implies
"this is for mempolicy, NUMA" and don't think good name for generic use.


 \ /
  Last update: 2009-12-11 01:45    [W:0.065 / U:5.100 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site