lkml.org 
[lkml]   [2009]   [Nov]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 00/27] writable limits

* Jiri Slaby <jirislaby@gmail.com> wrote:

> Hi,
>
> I broke the threading to not mess up with the long thread.
>
> In this version I got rid of the rlim access_only ugliness.

Thanks Jiri - this series looks very clean already and the helpers make
the various usage sites easier to understand as well.

One (very small) naming suggestion, please rename:

rlim_get_cur()
rlim_get_max()
task_rlim_get_cur()
task_rlim_get_max()

To a more natural sounding scheme like:

rlimit()
rlimit_max()
task_rlimit()
task_rlimit_max()

Reasons:

- 'cur' is a misnomer that came a decade+ ago from an ABI and there's
no need to continue that bad tradition in helper functions. It can
also be confused with 'curr' which we often use for the current task.

- 'rlimit' is general meme, plus there's no need to say it out aloud
that we 'get' it - rlimit() is obvious enough.

Beyond solving these issues it makes it shorter and more logical as
well.

Thanks,

Ingo


\
 
 \ /
  Last update: 2009-11-28 12:13    [W:0.168 / U:46.280 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site