[lkml]   [2009]   [Nov]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Weird suspend/resume problem on HP nx6325 w/ openSUSE 11.2 w/ -rc8
    On Sunday 22 November 2009, Dave Airlie wrote:
    > On Sun, Nov 22, 2009 at 9:15 AM, Rafael J. Wysocki <> wrote:
    > > Hi,
    > >
    > > I'm not really sure where this should be reported, but here it goes.
    > >
    > > After installing openSUSE 11.2 on my testbed nx6325 I noticed that resume
    > > (from suspend to RAM) stopped working on it. Apparently, it hanged while
    > > switching from the console back to X and the box remained completely
    > > unresponsive after that (it didn't even react to the magic sysrq). However,
    > > it used to work just fine with -rc7 and openSUSE 11.1, so I figured the problem
    > > was related to the new X driver, which is radeon module version 6.12.4 (xorg
    > > server 1.6.5).
    > >
    > > So, I started to investigate and found that after a suspend from a framebuffer
    > > console, the resume had always worked. However, when I switched from X to the
    > > framebuffer console, suspended, resumed and switched back to X, the box hanged
    > > immediately just like during resume after a suspend from under X. [There also
    > > were some problems when switching from X to the framebuffer console and back
    > > which seemd to be independent of suspend/resume (in short, the screen stays
    > > black after a switch from the framebuffer console to X and you need to kill X
    > > to fix this).]
    > You are using radeonfb on it? or vesafb?


    > first test is to try without either of those installed.

    That doesn't change the behavior AFAICS.

    > From memory though that machines an Xpress 200M

    Yes, it has this one.

    > which is the the worst graphics card for use with open drivers and has
    > always caused no-end of pain.

    Too bad. :-(

    > Its also mostly undocumented when it comes to errata and workarounds.

    Well, so I guess this is a hardware errata.

    Still, it worked with the older X, so I wonder if I can make the new X work
    like the old one?


     \ /
      Last update: 2009-11-27 02:07    [W:0.024 / U:0.116 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site