lkml.org 
[lkml]   [2009]   [Nov]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [tip:core/rcu] rcu: Remove inline from forward-referenced functions
    On Wed, Nov 11, 2009 at 08:02:08AM +0100, Ingo Molnar wrote:
    >
    > * Paul E. McKenney <paulmck@linux.vnet.ibm.com> wrote:
    >
    > > On Tue, Nov 10, 2009 at 08:50:13PM -0800, Paul E. McKenney wrote:
    > > > On Tue, Nov 10, 2009 at 07:28:28PM -0800, Joe Perches wrote:
    > > > > On Tue, 2009-11-10 at 17:42 -0800, Paul E. McKenney wrote:
    > > > > > On Tue, Nov 10, 2009 at 05:03:41PM -0800, Joe Perches wrote:
    > > > > > > So maybe rename rcutree_plugin.h to rcutree_plugin.c and
    > > > > > > #include "rcutree_plugin.c" in rcutree.c instead.
    > > > > > Hmmm...
    > > > >
    > > > > Perhaps something like this:
    > > >
    > > > While I do very much appreciate your time and attention to this...
    > > >
    > > > My problem with this sort of thing is that when I tried it, it proved
    > > > fragile. Small changes required lots of rework of forward declarations.
    > > > Putting it at the end makes it work very nicely -- the list of forward
    > > > declarations doubles as documentation for the plugins, and the contents
    > > > of kernel/rcutree_plugin.h (or .c or whatever, either way I end up
    > > > violation about the same number of coding guidelines) is independent of
    > > > rearrangements of kernel/rcutree.c.
    > > >
    > > > The reason that I would really like to keep rcu_bootup_announce() as
    > > > a function is that it makes it trivial to collect RCU-flavor-dependent
    > > > boot-time information, if needed for some debugging effort. If I pull
    > > > the string out, this sort of thing becomes much more painful.
    > >
    > > And, as noted in our offline conversation, you are absolutely right
    > > that I need to add __init to both definitions of rcu_bootup_announce(),
    > > which I will do, with your Suggested-by.
    > >
    > > Fair enough?
    >
    > Yep, the __init markers are fair enough - but otherwise i wouldnt overdo
    > this - a casual glance at rcutree_plugin.h shows that it's special,
    > contains an implementation that is included once into kernel/rcutree.c.
    > No need for header guards or a rename.

    Sounds good, patch sent separately. ;-)

    Thanx, Paul


    \
     
     \ /
      Last update: 2009-11-11 20:49    [W:0.022 / U:32.548 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site