[lkml]   [2009]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] kernel.h: Add a never optimized away pr_dbg for printk(KERN_DEBUG pr_fmt(fmt)...)
On Tue, 13 Oct 2009, Joe Perches wrote:

> > pr_dbg() is horribly misnamed, it doesn't indicate why it exists vs.
> > pr_debug() at all.
> Partially true, it's reasonably named because it's very short.

It doesn't really matter how long it is if it doesn't accurately describe
what it does.

> > I'd suggest pr_debug_force(), even though it's much longer (although still
> > shorter than printk(KERN_DEBUG)).
> pr_dbg allows longer format strings without exceeding 80 chars.
> printk(KERN_DEBUG
> pr_debug_force
> pr_dbg_always
> pr_dbg_noopt
> Other suggestions?

The pr_dbg_* variations seem reasonable if the current pr_debug() were
changed to pr_dbg().

I suggest converting some mainline code to use whatever you end up calling
the !DEBUG variant, though, because this discussion is irrelevant if there
are no current use cases (in which case the patch is pointless).

 \ /
  Last update: 2009-10-14 06:35    [W:0.059 / U:8.464 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site