lkml.org 
[lkml]   [2009]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 13/16] percpu: remove per_cpu__ prefix.
On 10/14/2009 09:42 AM, Luck, Tony wrote:
>>> -#define __ia64_per_cpu_var(var) per_cpu__##var
>>> +#define __ia64_per_cpu_var(var) var
>>
>> IA64 could completely drop the macro? Tony?
>
> A #define that just returns its original argument untouched
> does seem to be a no-op. So I suppose we could just fix
> the dozen or so places where it is used to just use the
> variable directly.
>

Okay... I also don't seem to understand the more fundamental issue here,
which is:

Why are we dropping the prefix?

It may be "insufficient", but at least it stands out like a sore thumb
and makes mistakes harder. It would be a different thing if we could
actually use the TLS ABI, but we really can't.

-hpa


\
 
 \ /
  Last update: 2009-10-14 19:53    [from the cache]
©2003-2011 Jasper Spaans