lkml.org 
[lkml]   [2009]   [Oct]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectUSB regression: devices not initially recognized
From
Hi,

Using the Karmic beta of Ubuntu (linux-image-2.6.31-11-generic) my USB
keyboard and blutooth dongle no longer work on bootup. If I unplug
them and plug them back in then it works. I reported the bug here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/445160

which contains:

"""
Hi,

When booting into Karmic my Blutooth USB dongle and USB to PS2
keyboard adapter are not recognized until I unplug them and plug them
back in. In my dmesg (see attachment for the full version) I get error
messages like:

[ 3.028029] usb 7-1: new full speed USB device using uhci_hcd and address 2
[ 3.148023] usb 7-1: device descriptor read/64, error -71
[ 3.372524] usb 7-1: device descriptor read/64, error -71
[ 3.588019] usb 7-1: new full speed USB device using uhci_hcd and address 3
[ 3.708018] usb 7-1: device descriptor read/64, error -71
[ 3.936027] usb 7-1: device descriptor read/64, error -71
[ 4.153513] usb 7-1: new full speed USB device using uhci_hcd and address 4
[ 4.564074] usb 7-1: device not accepting address 4, error -71
[ 4.676023] usb 7-1: new full speed USB device using uhci_hcd and address 5
[ 5.088023] usb 7-1: device not accepting address 5, error -71
[ 5.088042] hub 7-0:1.0: unable to enumerate USB device on port 1

My USB mouse and USB sound card are correctly identified on boot-up.
Everything works fine in 9.04 so this seems like a regression.

Here is my lsusb after replugging the devices in:
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 007: ID 046d:c216 Logitech, Inc. Dual Action Gamepad
Bus 001 Device 006: ID 08bb:2704 Texas Instruments Japan
Bus 001 Device 005: ID 06b4:1c70
Bus 001 Device 003: ID 0424:a700 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1
Flash Card Reader/Writer (Internal/External)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 003: ID 0e8f:0020 GreenAsia Inc.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 034: ID 0c10:0000
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 0461:4d15 Primax Electronics, Ltd Dell Optical Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

And full dmesg is attached.

Let me know if I can test anything out.

Thanks.
"""

Any suggestions on how to track down the problem?
[unhandled content-type:application/x-gzip]
\
 
 \ /
  Last update: 2009-10-10 16:15    [W:0.047 / U:1.092 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site