[lkml]   [2009]   [Oct]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectSuspend to RAM on MSI PR200YA - do not recover, system immediately turns down

I am trying to make work "Suspend to RAM".
My laptop is MSI PR200YA, linux
kernel (fedora 11, 32bit),
the same is with
Motherboard - MSI 1221, graphics:
Mobile GM965/GL960 Integrated Graphics Controller

When I do suspend to RAM it seem to work ok, it sleeps.
But when I want to wake it, it only switches off (the power
LED stops blinking). If I'm having my notebook connected
to electricity, after start it don't start screen and keyboard.
Notebook is running, but there is no HDD activity according
to the LED indicator. When it is on battery, it normally starts,
as if I had switched it normally off. Every time after trying to
suspend it to RAM, on the next start I have
"last write to superblock in future".

I tried:
- suspend from "single" mode
- suspend from "single" mode with as many modules as possible rmmod'ed
- using "nomodeset"
- early suspend-to-RAM at boot test with "test_suspend=mem"
All with the same result.

I also tried using pm_trace, but this gave no useful results in dmesg
in the next boot. The clock was not changed by it (the documentation
said it would be).

I have attached printout of "lspci -vv" and "dmesg" after switching
pm_trace on.

I'd welcome any ideas how to debug this further.
I'm looking forward to your reply.
[unhandled content-type:application/octet-stream][unhandled content-type:application/octet-stream]
 \ /
  Last update: 2009-10-10 20:03    [W:0.061 / U:0.828 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site